Very Laggy Game
Incident Report for
Monkey Park
Resolved
The Lag Has Been Fixed!
Posted
Aug
09
,
2025
-
17:58
CST
Update
We Are Continuing Our Testing | Standby
Posted
Aug
07
,
2025
-
18:37
CST
Update
We Paused Our Testing, Resuming Later | Standby
Posted
Aug
07
,
2025
-
12:01
CST
Monitoring
A Fix Has Been Released To Close Beta, We Are Testing It At The Current Moment
Posted
Aug
07
,
2025
-
11:05
CST
Identified
We Believe To Have Found The Issue, We Will Be Release A Fix Soon
Posted
Aug
07
,
2025
-
10:52
CST
Investigating
We are looking for the source of this issue
Posted
Aug
06
,
2025
-
20:41
CST
This incident affected: Game.
×
Subscribe to Incident
Subscribe to updates for
Very Laggy Game
via . You'll receive .